找回密码
 注册
搜索
热搜: 回贴
  • 前程无忧官网首页 有什么好的平台可以
  • 最新的销售平台 互联网营销的平台有哪
  • 制作网页的基本流程 网页制作和网页设
  • 【帝国CMS】输出带序号的列表(数字排
  • 网站建设公司 三一,中联,极东泵车的
  • 织梦 建站 织梦网站模版后台怎么更改
  • 云服务官网 哪些网站有免费的简历模板
  • 如何建网站要什么条件 建网站要用什么
  • 吉林市移动公司电话 吉林省退休人员网
  • 设计类毕业论文 网站设计与实现毕业论
查看: 758|回复: 0

请高手指点

[复制链接]
发表于 2009-11-4 02:29:43 | 显示全部楼层 |阅读模式 IP:江苏扬州
Problem Description
Your task is to calculate the sum of some integers.

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.



Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.



Sample Input
2
4 1 2 3 4
5 1 2 3 4 5


Sample Output
10
15


我用C++写的程序,请高手修改一下,我就是那个输入不懂怎么写,并说明下思路,谢谢各位了
#include "iostream"
using namespace std;
int main()
{
    int N,M;
    int i;
    cin>>N;
    while(N--)
    {
        int sum=0;
        cin>>M;
        for(i=0;i<=M;i++)
        {
            sum+=i;
        }
        cout<<sum<<endl;
    }

    return 0;
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|小黑屋|最新主题|手机版|微赢网络技术论坛 ( 苏ICP备08020429号 )

GMT+8, 2024-10-1 07:37 , Processed in 0.185504 second(s), 13 queries , Gzip On, MemCache On.

Powered by Discuz! X3.5

© 2001-2023 Discuz! Team.

快速回复 返回顶部 返回列表