|
题目地址:
http://acm.jlu.edu.cn/joj/showproblem.php?pid=1490
题目:
time limint : 10s.........(给了这么长时间,我还是超时了,跑了11s,惭愧啊)
Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10.
The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:
A, B, and C map to 2
D, E, and F map to 3
G, H, and I map to 4
J, K, and L map to 5
M, N, and O map to 6
P, R, and S map to 7
T, U, and V map to 8
W, X, and Y map to 9
There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.
Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)
Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.
Input
The input will consist of several cases. The first line of each case specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.
Output
For each test case, generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:
No duplicates.
Sample Input
12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279
Sample Output
310-1010 2
487-3279 4
888-4567 3
我的代码:
#include <iostream>
#include <vector>
using namespace std;
class node
{
friend int main();
private:
char text[12];
int times;
};
int main()
{
while(1)
{
int n;
int k=0;
cin>>n;
char c[n][8];
while (k<n)
{
string a;
cin>>a;
remove_copy(a.begin(),a.end(),c[k],'-');
c[k][7]='\0';
for (int i=0;i<7;i++)
{
if (c[k] >= 'A' && c[k] <= 'O')
c[k] = char('2' + (c[k] -'A')/3);
if (c[k]=='P'||c[k]=='R'||c[k]=='S')
c[k]='7';
if (c[k] >= 'T' && c[k] <= 'Y')
c[k] = char('8' + (c[k] -'T')/3);
}
k++;
}
char cpare[n][8];
int ct=0;
vector<int> count(n,0);
vector<int> tag(n,0);
int have = 0;
for (int i=0;i<n;i++,ct++)
{
if (tag!=1)
{
strcpy(cpare[ct],c);
for (int j=0;j<n;j++) |
|