设为首页收藏本站

新微赢技术网

 找回密码
 注册
搜索
热搜: 回贴
查看: 1148|回复: 6
打印 上一主题 下一主题

[求助]一道比较简单的ACM题目

[复制链接]
跳转到指定楼层
1#
发表于 2009-11-4 00:55:39 | 只看该作者 回帖奖励 |正序浏览 |阅读模式
Problem Description

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
Input

The input will consist of a series of integers n, one integer per line.
Output

For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input

1
100
Sample Output

1
5050
7#
发表于 2009-11-4 00:55:45 | 只看该作者
int sum()
{
cout<<"Please input a series of integers(end with 0).\n";
int i,sum=0;
while(cin>>i,i!=0)
sum+=i;
return sum;
}
回复 支持 反对

使用道具 举报

6#
发表于 2009-11-4 00:55:44 | 只看该作者
这个题目int 可能不够的
回复 支持 反对

使用道具 举报

5#
发表于 2009-11-4 00:55:43 | 只看该作者
#include<iostream.h>
void main()
{
int n,temp,sum;
cout<<"请输入一个整数n:";
cin>>n>>endl;
for(temp=n;temp<=n;temp++)
{
sum+=temp;
}
cout<<sum<<endl;
}
回复 支持 反对

使用道具 举报

4#
发表于 2009-11-4 00:55:42 | 只看该作者
那数据大小呢 ?
回复 支持 反对

使用道具 举报

3#
发表于 2009-11-4 00:55:41 | 只看该作者
就是要求输入几个数据,输出他们的相加和,第一行表示输入几行数据
回复 支持 反对

使用道具 举报

2#
发表于 2009-11-4 00:55:40 | 只看该作者
这么简单?我是不是没读懂题目啊?
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

申请友链|小黑屋|最新主题|手机版|新微赢技术网 ( 苏ICP备08020429号 )  

GMT+8, 2024-11-19 00:52 , Processed in 0.128570 second(s), 9 queries , Gzip On, Memcache On.

Powered by xuexi

© 2001-2013 HaiAn.Com.Cn Inc. 寰耽

快速回复 返回顶部 返回列表