设为首页收藏本站

新微赢技术网

 找回密码
 注册
搜索
热搜: 回贴
查看: 1602|回复: 1
打印 上一主题 下一主题

搞不懂

[复制链接]
跳转到指定楼层
1#
发表于 2009-11-4 02:31:55 | 只看该作者 回帖奖励 |倒序浏览 |阅读模式
Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                  T otal Submission(s): 5900    Accepted Submission(s): 1368

Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!



Input
One N in one line, process to the end of file.



Output
For each N, output N! in one line.



Sample Input
1
2
3


Sample Output
1
2
6



我的程序:

#include "iostream"
using namespace std;
long fac(int n)
{
long f;
if (n==0||n==1)    f=1;
else f=fac(n-1)*n;
return f;
}
int main()
{
    int N;
    0<=N&&N>=10000;
    long y;
    while(cin>>N)
    {
        
        y=fac(N);
        cout<<y<<endl;
    }
    return 0;
}
我们学校网页里面编程练习的题,为什么在编译器上运行没问题,在那里提交就说wrrong  anwser呢??
2#
发表于 2009-11-4 02:31:56 | 只看该作者
0<=N&&N>=10000;这句是干什么的,N没有初始化,运行时这句肯定报错,而且看不出它的目的.
会不会是if(0<=N&&N>=10000).不关怎么,N不赋值就拿来做运算,运行期会出错.
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

申请友链|小黑屋|最新主题|手机版|新微赢技术网 ( 苏ICP备08020429号 )  

GMT+8, 2024-11-19 16:21 , Processed in 0.107761 second(s), 10 queries , Gzip On, Memcache On.

Powered by xuexi

© 2001-2013 HaiAn.Com.Cn Inc. 寰耽

快速回复 返回顶部 返回列表