设为首页收藏本站

新微赢技术网

 找回密码
 注册
搜索
热搜: 回贴
查看: 753|回复: 0
打印 上一主题 下一主题

请高手指点

[复制链接]
跳转到指定楼层
1#
发表于 2009-11-4 02:29:43 | 只看该作者 回帖奖励 |倒序浏览 |阅读模式
Problem Description
Your task is to calculate the sum of some integers.

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.



Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.



Sample Input
2
4 1 2 3 4
5 1 2 3 4 5


Sample Output
10
15


我用C++写的程序,请高手修改一下,我就是那个输入不懂怎么写,并说明下思路,谢谢各位了
#include "iostream"
using namespace std;
int main()
{
    int N,M;
    int i;
    cin>>N;
    while(N--)
    {
        int sum=0;
        cin>>M;
        for(i=0;i<=M;i++)
        {
            sum+=i;
        }
        cout<<sum<<endl;
    }

    return 0;
您需要登录后才可以回帖 登录 | 注册

本版积分规则

申请友链|小黑屋|最新主题|手机版|新微赢技术网 ( 苏ICP备08020429号 )  

GMT+8, 2024-11-19 07:34 , Processed in 0.093086 second(s), 10 queries , Gzip On, Memcache On.

Powered by xuexi

© 2001-2013 HaiAn.Com.Cn Inc. 寰耽

快速回复 返回顶部 返回列表